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Important: 
Before installing any equipment be sure to consult the specifications in this manual. 
Failure to do so may cause integration problems. Portions of this integration manual may 
be changed without prior notice. 
 
Note: 
Losses that can be attributed to improper installation and working procedures are not the 
responsibility of TransAct Technologies Inc. No part of this manual may be used to 
recreate any part of the Epic 950TM Printer. This manual is to be used for integration 
purposes only. If this manual contains any questionable information or mistakes please 
contact TransAct for assistance. 
 

Disclaimer 
NOTICE TO ALL PERSONS RECEIVING THIS DOCUMENT:  
The information in this document is subject to change without notice. No part of this 
document may be reproduced, stored or transmitted in any form or by any means, 
electronic or mechanical, for any purpose, without the express written permission of 
TransAct Technologies, Inc. ("TransAct").  This document is the property of and contains 
information that is both confidential and proprietary to TransAct.   Recipient shall not 
disclose any portion of this document to any third party. 
 
TRANSACT DOES NOT ASSUME ANY LIABILITY FOR DAMAGES INCURRED, 
DIRECTLY OR INDIRECTLY, FROM ANY ERRORS, OMISSIONS OR 
DISCREPANCIES IN THE INFORMATION CONTAINED IN THIS DOCUMENT. 
 
TransAct cannot guarantee that changes in software and equipment made by other 
manufacturers, and referred to in this publication, do not affect the applicability of 
information in this publication. 
 

Copyright 
©  2005 TransAct Technologies, Inc.  All rights reserved. 
Revision Level A 
April 2005 
Printed in USA 
 

Trademarks 
Some of the product names mentioned herein are used for identification purposes only 
and may be trademarks and/or registered trademarks of their respective companies. 
 
BANKjet, 50Plus, Insta-Load, Ithaca, "Made to Order. Built to Last", Magnetec, PcOS, 
POSjet, PowerPocket and TransAct are registered trademarks and Epic 950, Flex-Zone, 
imPort, ithaColor, iTherm, KITCHENjet, Momentum, QDT and TicketBurst are 
trademarks of TransAct Technologies, Inc. 
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Epic 950 Layout Editor User’s Guide 
 
 

Who Should Read This Guide? 
 
This document provides information useful to operators who will integrate Epic 950TM or 
compatible printers into their products. 
 

What is Included In This Guide? 
 
This document provides information on how to use the Epic 950TM Layout Editor, a 
standalone application for creating layout files of ticket images to be used in Epic 950TM 
or compatible thermal printers. 
 
Refer to the Epic 950 OEM Integration Manual for complete information on the 
mechanical, electrical, and command language requirements of the Epic 950 printer, not 
covered in this User’s Guide. 
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Epic 950 Layout Editor Features 
 
 
The Epic 950 Layout Editor is a convenient tool for laying out the graphic design of 
gaming tickets or vouchers for TransAct Epic 950-compatible thermal printers. Key 
features include: 

• A pre-defined workspace in the dimensions (5.25'' x 2.5") of a gaming ticket or 
voucher.  

• Functions for adding text, graphics and barcodes to the ticket layout.  
• A convenient layout grid for placement of design elements.  
• Customize, align, or resize a group of selected objects.  
• Save ticket layout files in an internal (.spl file) format, for future editing.  
• Export ticket layout files (.lay) for download to your printer. 
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Program Overview 
 
This program is designed to work in conjunction with existing graphics image files to 
create a ticket layout for export to your printer. The normal sequence of operations is as 
follows: 

1) Open a new or existing (.spl file) ticket layout using the "File" -> "Open" menu 
function, which opens in the drawing panel shown below. The program opens a blank 
ticket layout by default. 

 

 
Figure 1. The drawing panel 

 
The drawing panel is a 5.25'' x 2.5'' canvas, within which a ticket can be designed. While 
designing tickets, objects included on a ticket can be text, a bitmap, or a barcode. 
Functions within this drawing panel include:  

• Insert a barcode object, a bitmap object, or a text object, using the Drawing 
toolbar.  

• Customize a selected object using the Properties function.  
• Group selected objects to resize, move, alignment, copy, or delete, using the 

Structure toolbar.  
• Align objects using the Alignment toolbar. 

Toolbar and menu functions are outlined in subsequent sections of this manual. 
 
The size and units, drawing scale and coordinate mapping of the drawing panel can be 
displayed and modified using the Measurements menu ("Edit" -> "Measurements") 
 
2) Layout and modify text, graphics and/or bar code design elements, using the Edit 
menu and/or Drawing toolbar options. 
 
3) Save your ticket layout via the "File" -> "Save" or "File -> "Save As" menu option  
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4) Export your ticket layout into an export (.lay) file. This export file contains a reference 
to a bitmap file of the naming convention FieldXName.bmp, created when the file is 
exported.  
 
5) Use the TransAct File Transfer Utility (distributed separately) to download this layout 
file to your printer. Contact TransAct technical support for further information on the 
TransAct File Transfer Utility program. You may also print the ticket directly from the 
application. 
 
 

 
 
 



  Epic 950 Layout Editor User’s Guide 
 

April 2005 – Rev A  Page 7 

 

Toolbar Functions 
 
The toolbar provides access to the main file management, drawing and layout tools, as 
well as convenient icons for numerous menu functions. Individual toolbar functions are 
documented below. 
 

Main Toolbar 
 

  
 
The Main toolbar provides the following tools, in the order shown on the above image:  

• Start a new ticket design  
• Open an existing ticket document  
• Save the active ticket document  
• Cut the selection, and put it on the clipboard  
• Copy the selection, and put it on the clipboard  
• Insert the clipboard content  
• Print the active ticket  
• Display program information, version number and copyright  

 

Drawing Toolbar 
 

  
 
The Drawing toolbar provides the following tools, in the order shown on the above 
image:  

• Select, resize or move components. Select an object by clicking on it. You can 
then move the object by clicking and dragging within the object, or resize it by 
clicking and dragging one of its "handles" around the edge of the object. 

• Show the properties of the selected object such as bitmap, or barcode, or text. 
Properties are described in detail in a subsequent section. 

• Insert text. After selecting this option, clicking on the drawing panel will insert a 
default text box. You can then move or resize this box, revise the text by 
highlighting and re-typing it, or change its properties. 

 

 
Figure 2. Sample text. 
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• Insert an image (a .bmp image). You will be prompted to specify a graphics file in 

bitmap (.bmp or .dib) format. You can then move or resize this image, or change 
its properties. 

 

 

Figure 3. Sample image. 

 
• Insert a barcode. After selecting this option, clicking on the drawing panel will 

insert a default barcode template box. You can then move or resize this box, or 
change its properties, including bar code type. 

 

 
Figure 4. Sample barcode template. 

 
• Rotate selected component 90 degrees counter clockwise. 
• Rotate selected component 90 degrees clockwise. 

 
 

Structure Toolbar 
 

 
 
The Structure toolbar provides the following tools, in the order shown on the above 
image:  

• Group components  
• Ungroup grouped components  
• Bring the selection to front  
• Send the selection to back  
• Bring the selection forward  
• Send the selection back  
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Alignment Toolbar 
 

 
 
 
The Alignment toolbar is used to align multiple selected objects. (You can select multiple 
objects on your layout by holding down the CTRL key while selecting individual objects.) 
This toolbar provides the following tools, in the order shown on the above image:  

• Align tops of objects 
• Align midpoints of objects 
• Align bottoms of objects 
• Align left sides of objects 
• Align centers of objects 
• Align right sides of objects 
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Menu Functions 
 
Menu options provide access to key file management, editing and viewing functions. 
Many of these functions are also available via icons on the toolbar. 
 

File Menu 
 
The File menu contains the following options: 

• New Ctrl+N  
Create a new ticket layout document.  

• Open... Ctrl+O  
Open an existing ticket layout document from an existing .spl file.  

• Save Ctrl+S  
Save changes to a ticket layout document. Files are saved in an internal format 
under the name filename.spl. 

• Save As  
Rename the ticket layout document.  

• Export...  
Export a ticket layout file (.lay) containing a bitmap image, for download to your 
printer. 

• Export180...  
Export a ticket layout file (.lay) containing a bitmap image, for download to your 
printer, rotated 180 degrees.  

• Print...  
Send the ticket to your TransAct printer for printing.  

• Print Preview  
Preview the ticket before printing.  

• Print Setup  
Setup your TransAct printer.  

• Exit  
Exit from Epic 950 Layout Editor. 

 

Edit Menu 
 
The Edit menu contains the following options:  

• Undo Ctrl+Z 
Roll back one action, such as undoing a cut, delete, copy, paste, or alignment 
operation.  

• Redo Ctrl+Y  
Repeat the previous action.  

• Cut Ctrl+X 
Move one selected object or a group of selected objects to the clipboard.  
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• Copy Ctrl+C 
Copy one selected object or a group of selected objects to the clipboard. Note 
that this function does not apply to bitmap objects.  

• Paste Ctrl+V 
Copy from the clip board to drawing panel. Note that this function does not apply 
to bitmap objects; to duplicate a bitmap object, simply insert it again.  

• Delete Del 
Delete one selected object or a group of selected objects.  

• Properties... 
Display and modify the properties of a selected object. Properties are discussed 
in more detail in a subsequent section. 

• Default Properties... 
Display and modify default properties for new objects. Default properties are 
discussed in more detail in a subsequent section. 

• Measurements...  
Display and modify the size and units, drawing scale and coordinate mapping of 
the drawing panel.  

 

View Menu 
 
The View menu contains the following options:  

• Zoom Normal 
Returns the ticket display to a zoom level of 100% from a previous value. Note: 
This option is grayed out when the zoom level is already 100%. 

• Zoom Percent 
This menu option allows to zoom the ticket display to 50%, 75%, 100% (the 
original size), and 200% of its original size.  

 

Help Menu 
 
The Help menu contains the following options:  

• Help Topics 
Displays the program help file.  

• About Ticket Layout Editor 
Provides current version information for the Epic 950 Layout Editor program.  
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Properties 
 
The Properties menu or toolbar option controls various display and layout options for a 
selected object, via a menu of property options that are specific to the selected object 
type. This menu is accessed via “Edit” -> “Properties” on the main menu, or the 
Properties icon on the Drawing toolbar. 
 
The specific menu displayed is based on the type of object selected, as follows: 
 

Text object properties 
 
The menu appears when the Properties option is chosen with a text object selected. 
Tabs within this menu control settings as follows: 
 
General tab 
 

 
 
This tab contains an addressable name for the selected object, which can be changed 
within this menu, and the object type. 
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Edit tab 
 

 
 
The Edit tab controls editing options for the selected object, including the following 
options: 
 
Allow Property Change: A general toggle that turns on or off the ability to make 
property changes for this object. 
Read Only: Selecting this box locks the object from further editing, and grays out the 
other options on this menu. 
Allow Selection: Allows the object to be highlighted for property change or editing 
operations. 
Allow Move: Allows object to be moved by clicking and dragging the object. 
Allow Rotation: Allows object to be rotated (reserved for future use). 
Allow Vertex Editing: Allows modifying vertex locations by clicking and dragging vertex 
“handles” on object. 
Allow Scaling: Allows size to be changed by clicking and dragging vertices. 
Allow Stretch: Allows aspect ratio (height to width) to be changed by clicking and 
dragging vertices. 
Critical: This option specifies this object as a critical field, whose printing status can be 
returned as part of the printer status. Consult the Epic 950 Smart Suite Supplement for 
further details on critical fields and printer status. 
 



  Epic 950 Layout Editor User’s Guide 
 

April 2005 – Rev A  Page 15 

 
Text tab 
 

 
 
The Text tab controls the text content, and its layout and alignment. Options include: 
 
Text: Shows the displayed text, and allows the text content to be modified as needed. 
Multiple Lines: When checked, this box allows the text string to span multiple lines, 
base on the string length relative to the size of the text box. 
Word Break: This option is only available when the Multiple Lines option is checked, 
and controls whether long words can break when a text string spans multiple lines. 
Horizontal Alignment: Select Left, Center or Right alignment 
Vertical Alignment: Select Top, Center or Bottom alignment. 
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Line tab 
 

 
 
The Line tab sets the color, line style and line width for an optional border line around 
the object. The “Transparent” option will gray out these options and result in no border. 
 
Fill tab 
 

 
 
The Fill tab sets a foreground color, background color and hatch pattern for the object. 
Either color will fill the text field, with the foreground as an overlay onto the background 
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color – so, for example, a foreground color with a diagonal hatch pattern will show the 
background color behind it. 
 
The Transparent Fill option and Transparent Background options will make these colors 
transparent. Note that selecting Transparent Fill will gray out all other options. 
 
 
Font tab 
 

 
 
The font tab controls text font settings including font type, style, size and color, as well 
as check boxes for Underline and Strike-Out text. 
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Position and Size tab 
 

 
 
The Position and Size tab provides a read-only display of the object’s origin location and 
dimensions. Origin coordinates reflect the location of the upper right-hand corner of the 
object. 
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Bitmap (bmp) object properties 
 
 

 
 
 
For bitmap images, the Properties menu contains the same General, Edit and Position 
and Size tabs as described above for Text objects, as well as the following tab: 
 
Image Attribute – specifies ticket color, image compression (saves space) and dithering 
options, with an image preview option. Dithering is a technique that emulates multiple 
colors as dot patterns of fewer colors (in this case, a single color). The first two dithering 
techniques have color threshold settings that can be set via sliders as shown, while the 
second two dithering techniques use fixed threshold values. 
 



  Epic 950 Layout Editor User’s Guide 
 
 

April 2005 – Rev A  Page 20 

 

Barcode object properties 
 

 
 
For barcode templates, the Properties menu contains the same General, Edit and 
Position and Size tabs as described above for Text objects, as well as the following tab: 
 
Bar Code  - specifies bar code type (encoding format), aspect ratio, and alignment within 
the bar code template field. 
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Default Properties 
 
The Default Properties menu, accessed via “Edit” -> “Default Properties” from the main 
menu, is used to select default properties used for subsequent newly created objects. 
Options include: 
 

• Edit - toggle object editing capabilities such as move, scaling, etc. 
• Labels - label orientation 
• Line - line attributes 
• Fill - object fill attributes 
• Font - text font and size attributes 

 

 

Note: Many of these options are similar in format to corresponding 
Properties options, documented in a previous section. Properties options 
are applied to a selected object, while Default Properties apply to new 
objects. 

 
 
Edit tab 
 

 
 
 
The Edit tab controls editing options for the selected object, including the following 
options: 
 
Allow Property Change: A general toggle that turns on or off the ability to make 
property changes for this object. 
Read Only: Selecting this box locks the object from further editing, and grays out the 
other options on this menu. 
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Allow Selection: Allows the object to be highlighted for property change or editing 
operations. 
Allow Move: Allows object to be moved by clicking and dragging the object. 
Allow Rotation: Allows object to be rotated. 
Allow Vertex Editing: Allows modifying vertex locations by clicking and dragging vertex 
“handles” on object. 
Allow Scaling: Allows size to be changed by clicking and dragging vertices. 
Allow Stretch: Allows aspect ratio (height to width) to be changed by clicking and 
dragging vertices. 
Critical: Reserved for future use. 
 
 
Labels tab 
 

 
 
The Labels tab allows you to specify an orientation and offset coordinate values for text 
labels. 
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Line tab 
 

 
 
The Line tab sets the color, line style and line width for an optional border line around a 
text object. The “Transparent” option will gray out these options and result in no border. 
 
Fill tab 
 

 
 
 
The Fill tab sets a foreground color, background color and hatch pattern for the object. 
Either color will fill the text field, with the foreground as an overlay onto the background 
color – so, for example, a foreground color with a diagonal hatch pattern will show the 
background color behind it. 
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The Transparent Fill option and Transparent Background options will make these colors 
transparent. Note that selecting Transparent Fill will gray out all other options. 
 
Font tab 
 

 
 
The font tab controls text font settings including font type, style, size and color, as well 
as check boxes for Underline and Strike-Out text. 
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Ticket design samples 
 
The following are graphic images of sample tickets, as examples of completed layouts. 
 
Example 1: House of Moola 
 

 
 
Example 2: This Could Be You 
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Example 3: Palm Garden Restaurant 
 

 
 
Example 4: Play to Win 
 

 
 
 

 
 
 


